Results 1 to 4 of 4

Thread: Ubuntu 10.04 on Nokia Booklet 3G

  1. #1
    Join Date
    Jan 2007
    Posts
    109
    Rep Power
    0

    Default Ubuntu 10.04 on Nokia Booklet 3G

    I am doing a dual boot of Win 7 and Ubuntu Lucid on my Nokia Booklet 3G... everything works fine except when I am using ubuntu and I unplug the charger the hard drive keeps trying to spin down and it makes this knocking sound... I did some research on it and it seems that Ubuntu has issues with hard drives when it goes into laptop mode...

    I installed laptop mode tools and mess with the config file but it still won't help... has anyone had this problem before and is there a way I can fix this...
    Device:Samsung® Galaxy S4 OS: Android 4.2.2
    POWERED By: Verizon™

  2. #2
    Join Date
    Jul 2002
    Posts
    1,388
    Rep Power
    0

    Default

    Bravo. That's an interesting device to experiment on. But you should go with a Netbook-specific spin. Maybe UNR or Easypeasy. Surely, you also read that messing with the Spin up/down settings may severly damage/destroy your drive? Here is a wiki from the distro that I use which should be very helpful in your choice of options with your distro. http://wiki.archlinux.org/index.php/Laptop

    Good luck! and post some info re your driver support and such. Like maybe a hardinfo report?
    Sharing is caring? Then what if I care too much? A precarious situation, indeed...
    http://ip-check.org/ip-check.png

  3. #3
    Join Date
    Jan 2007
    Posts
    109
    Rep Power
    0

    Default

    I would prefer to just turn off laptop-mode all together... as it seems no matter what I do with tweaking the power mode config file as soon as I unplug the charger I hear the hard drive making a ticking sound... I really prefer ununtu 10.04 over windows 7 starter but I can't afford to wreck my hard drive.

    when I go to etc>laptop-mode>laptop-mode.conf and I set ENABLE_LAPTOP_MODE_ON_BATTERY=0 ... this should disable it according to the manual but it doesn't help at all.
    Device:Samsung® Galaxy S4 OS: Android 4.2.2
    POWERED By: Verizon™

  4. #4
    Join Date
    Jan 2007
    Posts
    109
    Rep Power
    0

    Default

    Got it fixed... Had to go to
    edit /etc/default/acpi-support and paste ENABLE_LAPTOP_MODE=true at the end of the file...After that I changed a few settings in the Laptop-Mode.conf file...

    changed the HD settings, in my case it was HD="/dev/hda" and then in # Power management for HD (hdparm -B values)... I changed BATT_HD_POWERMGMT=1 value to 254

    After that I turned on or enable Laptop mode with this command: # echo 5 > /proc/sys/vm/laptop_mode.... Then lastly I called the laptop mode file with this command:
    /etc/init.d/laptop-mode restart... That was it, the clicking went away...

    Ubuntu is very quick on this netbook, it's far more responsive than windows 7 starter... it's a lot more fun to use with it's built in communication functionalities such as IMs and Social Networking...
    Don't know why Nokia opted for windows 7 in the first place, Ubuntu and Netbooks are a perfect match.
    Device:Samsung® Galaxy S4 OS: Android 4.2.2
    POWERED By: Verizon™

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •