Results 1 to 8 of 8

Thread: Troubleshooting WOL/W

  1. #1
    Join Date
    Jan 2009
    Posts
    2,404
    Rep Power
    0

    Default Troubleshooting WOL/W

    OK, I have a small network of two computers - Dell Optiplex GX 150 and eMachines EL1200-01e - along with a Linksys 5-port hub and C&W Zhone (6211, I think) modem. I setup VNC on both systems as I only have one monitor, and I also forwarded couple ports so I can access my systems via the internet.

    The problem I'm having is that the Wake-On-LAN function isn't working for some reason. The first time I setup and tested booting using Solar Winds WOL on the LAN, it worked great. Then I tried connecting from work and it didn't work, using the forwarded ports and MAC. Isn't working at home again either for some reason, and I didn't change anything. BTW, I ensured that its on in BIOS.

    The hub has two rows of status lights ("Link/Act" and "100"), with the first flashing based on activity. The modem and Dell connections always cause both lights to be on once they're plugged in. But the emachines has the "100" light off when powered down and both off if power is lost completely to the system (even when power is returned). I know that it's in the former mode that WOL/W will work, and I've noticed that its NIC will flash sometimes when its off. I'm pretty sure the Dell would turn on in a snap via WOL, though I haven't tried it yet.

    Thing is, the emachines is my work system, which I kinda treat like a server, since I use it both from my personal system and via Internet. Would like to get this working (at least the WOL side) as I dislike leaving my computer on so I can access it.
    Rooted OnePlus 2 64GB Ed, Android 5.1.1 OxygenOS ; on teifin' AT&T's network; Rooted ASUS Transformer TF101 w/ dock, Android 5.1 KatKiss; Laptop: ASUS X550C, 2.0GHzx2, 8GB, 512GB SSD, Kubuntu 15.10;
    Facebook page: Skeleville Technology Solutions

  2. #2
    Join Date
    Jan 2009
    Posts
    2,404
    Rep Power
    0

    Default

    Hmm. Interesting. WOL works after a soft restart. Seems that the way the system is shutdown affects if power remains in the NIC or not. Just need to figure out how to keep the power in hibernation...
    Rooted OnePlus 2 64GB Ed, Android 5.1.1 OxygenOS ; on teifin' AT&T's network; Rooted ASUS Transformer TF101 w/ dock, Android 5.1 KatKiss; Laptop: ASUS X550C, 2.0GHzx2, 8GB, 512GB SSD, Kubuntu 15.10;
    Facebook page: Skeleville Technology Solutions

  3. #3
    Join Date
    Jan 2009
    Posts
    2,404
    Rep Power
    0

    Default

    *sigh*. The saga of my WOL troubles continue. I have reconfigured my system based on instructions in various forums, guides, etc, but I have yet to get the results they have achieved. My problem has been distilled down to the NIC; or why the OS powers it down on standby/hibernate but not on shutdown. Maybe this problem is specific to only some NICs, like the on board Nvidia nForce, since my on board 3com doesn't theoretically have this issue.

    I guess its time to research and dig deeper into Windows than I ever had. I need to find out how Windows treats the various power down states differently. From this I should know if a software can be used to keep the NIC on, the OS itself needs some kind of patching, or some kind of hardware configuration needs to be manually tweaked. I got a hint where someone had WOL issues on shutdown with Win2k, and this was solved by an OS patch...

    And when I finally have this solved (which I eventually will), it will be WOW time!
    Rooted OnePlus 2 64GB Ed, Android 5.1.1 OxygenOS ; on teifin' AT&T's network; Rooted ASUS Transformer TF101 w/ dock, Android 5.1 KatKiss; Laptop: ASUS X550C, 2.0GHzx2, 8GB, 512GB SSD, Kubuntu 15.10;
    Facebook page: Skeleville Technology Solutions

  4. #4
    Join Date
    Sep 2004
    Posts
    1,800
    Rep Power
    18

    Default

    Quote Originally Posted by Skele Drew View Post
    *sigh*. The saga of my WOL troubles continue. I have reconfigured my system based on instructions in various forums, guides, etc, but I have yet to get the results they have achieved. My problem has been distilled down to the NIC; or why the OS powers it down on standby/hibernate but not on shutdown. Maybe this problem is specific to only some NICs, like the on board Nvidia nForce, since my on board 3com doesn't theoretically have this issue.
    I am having the same problem in Windows 8.

    Hibernate S4 works, but shutdown S5 does not.

    The NIC is set to WOL in S3, S4 and S5 in the BIOS and Windows (All settings in Bios and Windows need to be set for it to work in S5. I will post later). However I suspect windows 8 or nic driver is not doing what it is supposed in S5. It works up to 5 seconds after a shutdown when NIC still has residual power, but after Hibernation, even the next day, a WOL Magic Packet will start up the PC from S4.
    A fallen Real Super Hero rest in our hearts. Wakanda Forever!
    Black Lives Matter

  5. #5
    Join Date
    Nov 2004
    Posts
    4,976
    Rep Power
    20

    Default

    I'm willing to assist you with testing a theory.

    I can setup some software on your devices temporarily and then you let the work machine hibernate. I can then send a WOL from the other machine remotely and see if it will wake. If it does, then the problem may be with the way the WOL is initiated from whatever device you're using.

    Sorry for not responding sooner as I did not see the post.

    Go to khat17.screenconnect.com and start sessions from both machines - we can test and post the results right away once you're ready. Just let me know the names you'll use for the two systems.
    Last edited by khat17; Jun 27, 2020 at 10:33 PM.
    Knowing the solution doesn't mean knowing the method. Yet answering correctly and regurgitation are considered "learning" and "knowledge".

  6. #6
    Join Date
    Sep 2004
    Posts
    1,800
    Rep Power
    18

    Default

    Quote Originally Posted by khat17 View Post
    I'm willing to assist you with testing a theory.

    I can setup some software on your devices temporarily and then you let the work machine hibernate. I can then send a WOL from the other machine remotely and see if it will wake. If it does, then the problem may be with the way the WOL is initiated from whatever device you're using.

    Sorry for not responding sooner as I did not see the post.

    Go to khat17.screenconnect.com and start sessions from both machines - we can test and post the results right away once you're ready. Just let me know the names you'll use for the two systems.


    Sincere thanks Khat17



    I don't think it is the format of the WOL or how that is initiated, as when I do a S5 (shutdown) on the remote PC, I am able to wake it within 5 seconds. Also when I do a S4 (Hibernate) of the remote PC, I am able to wake it at any time.

    Theses are my settings. I still don't get it to work.

    BIOS

    ACPI Settings/WakeUp Event Control
    • EuP Control - Disabled (needed)
    • (ACPI Sleep State - S3 only)
    • PME Wake up from S5 - Enabled (needed)
    • (Ring-In Wake up from S5 - Enabled)
    • (USB Device Wakeup from S3/S4 - Enabled)

    Network Stack
    • Network Stack - Enabled (needed)
    • (IPv4 PXE Support - Enabled)
    • (IPv6 PXE Support - Enabled)

    Onboard Device
    • (Onboard LAN Option ROM - Enabled)

    CSM Parameters
    • (Launch PXE OpROM policy - Legacy only)

    no SecureON Password option

    Windows 8

    Control Panel -> Power Options -> Choose what the power buttons do ->
    Turn on fast startup (recommended) - unchecked
    Save changes.

    Control Panel -> System -> Device Manager -> Network Adapters ->
    Right click on 'the network card name' and click Properties
    Power Management (tab)
    • Allow the computer to turn off this device to save power - Checked
    • Allow this device to wake the computer - Checked (needed)
    • Only allow a magic packet to wake the computer - Checked

    Advanced (tab)
    • Network Address - Value set to xxx.xxx.xxx.xxx
    • Shutdown Wake-On-Lan - Enabled
    • Wake on Magic Packet - Enabled
    • Wake on pattern match - Enabled
    • WOL & Shutdown Link Speed - Not Speed Down




    Reboot once. Then Shutdown, and Test.

    If no WOL magic packet boot, then manual Boot, then Hibernate, and then Test again.

    If WOL magic packet works in hibernate mode but not in shutdown mode, it could be a driver issue with windows 8.

    I even updated the bios but no change, but I do not recommend this at all. I suspect its a software issue.

    Send WOL packet using Powershell
    Open Power Shell in administrator mode. Download and review code in notepad before pasting in Power Shell. Then use, as example:
    Send-WOL -mac 00:11:32:21:2D:11 -ip 192.168.8.255 -port 7

    Quote Originally Posted by Skele Drew View Post
    I guess its time to research and dig deeper into Windows than I ever had. I need to find out how Windows treats the various power down states differently. From this I should know if a software can be used to keep the NIC on, the OS itself needs some kind of patching, or some kind of hardware configuration needs to be manually tweaked. I got a hint where someone had WOL issues on shutdown with Win2k, and this was solved by an OS patch...
    I did some research and Windows 8 seem to change up the support on WOL.

    Ensure that network driver is updated, so that NIC keeps in a "powered on" state when the PC is shutting down (provided all WOL settings are available and set)

    I updated my NIC driver but no change. I advise doing this first, because I suspect the problem is still here.

    Here are some research links:

    What Is Wake-on-LAN, and How Do I Enable It?



    FAQ - How to set Wake On Lan (WOL)under windows 10

    Unwanted wake-up events may occur when you enable the Wake On LAN feature in Windows 7 or in Windows Vista

    Wake on Lan password
    A fallen Real Super Hero rest in our hearts. Wakanda Forever!
    Black Lives Matter

  7. #7
    Join Date
    Sep 2004
    Posts
    1,800
    Rep Power
    18

    Default

    Guess I am stuck with using Hibernate, even after all these settings.

    "Wake on LAN"(WOL) behavior in Windows 8, Windows 8.1 and Windows 10
    https://support.microsoft.com/en-ca/...and-windows-10



    The "Wake on LAN" (WOL) feature wakes a computer from a low-power state when a network adapter detects a WOL event. Typically, such an event is a specially constructed Ethernet packet. The default behavior in response to WOL events has changed from Windows 7 to Windows 8 and Windows 10.

    In Windows 8, 8.1 and Windows 10, the default shutdown behavior puts the system into the hybrid shutdown (also known as Fast Startup) state (S4), and all devices are put into D3. In this scenario, WOL from S4 or S5 is unsupported. Network adapters are explicitly not armed for WOL in these cases because users expect zero power consumption and battery drain in the shutdown state. This behavior removes the possibility of invalid wake-ups when an explicit shutdown is requested. Therefore, WOL is supported only from sleep S3, or when the user explicitly requests to enter hibernate (S4) state in Windows 8, 8.1 and Windows 10. Although the target system power state is the same between hybrid shutdown and hibernate (S4), Windows will only explicitly disable WOL when it's a hybrid shutdown transition, and not during a hibernate transition.

    Note the firmware and hardware on some systems may support arming Network Interface Cards (NICs) for wake from S4 or S5, even though Windows isn't involved in the process.
    A fallen Real Super Hero rest in our hearts. Wakanda Forever!
    Black Lives Matter

  8. #8
    Join Date
    Nov 2004
    Posts
    4,976
    Rep Power
    20

    Default

    Still would want to try for science!
    Knowing the solution doesn't mean knowing the method. Yet answering correctly and regurgitation are considered "learning" and "knowledge".

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •