Results 1 to 3 of 3

Thread: Problems browsing with Digicel

  1. #1
    Join Date
    Dec 2004
    Posts
    2,038
    Rep Power
    0

    Default Problems browsing with Digicel

    Anybody having problems browsing for the past 3 or so weeks? I've tried shutting off LTe and just work with 4G but same issue. Email and stuff like whatsapp msgs work but cant load status or web pages watch vids, etc.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    You assume all risk for your use. 2006 Cloud Solutions. All rights reserved.

  2. #2
    Join Date
    Aug 2016
    Posts
    538
    Rep Power
    4

    Default

    Quote Originally Posted by Cloud View Post
    Anybody having problems browsing for the past 3 or so weeks? I've tried shutting off LTe and just work with 4G but same issue. Email and stuff like whatsapp msgs work but cant load status or web pages watch vids, etc.
    Yes, LTE signal is weak. I too switched to 4G only. But still had issues browsing the internet. It has gotten better since yesterday. But still have intermittent connection. LTE on the other hand, is still weak and unusable. Digicel has made commitments to fix the LTE issues in my Area and Three Miles. Still waiting for that to get done, how's your data connection now. Still having these issues frequently, or its in between?.

  3. #3
    Join Date
    Dec 2004
    Posts
    2,038
    Rep Power
    0

    Default

    Mine isn't intermittent just full time can't do anything other than WhatsApp msgs minus pics and vids. It's a postpaid account but called CC this morning and they reset the account and advised a restart but no change. I'm located in Mobay btw

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •